<!DOCTYPE html>
<html lang='en'>
<head>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/favicon_w16-e08ac47245c9fd393666430866af2f79faad235b2ddb292add9e5a709fc814e3.png' rel='icon' sizes='16x16' type='image/png'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/favicon_w32-d490c5b731fde1ea926d750b03b2708f50ded63ed2259ea69b072c497f1f7588.png' rel='icon' sizes='32x32' type='image/png'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/favicon_w96-1dd840a8724cd9d9ce2830d47000689c0155b0eb181c733aec6bf2a45c83666c.png' rel='icon' sizes='96x96' type='image/png'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/favicon_w160-63a25532992727d1edd94f937cdda16a189e18cee11210799bf30eb7be742cc6.png' rel='icon' sizes='160x160' type='image/png'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/favicon_w196-968f18909ca09bd1a8a1d798d7d0ccae276d1c70a4d2dd940b1ab448e5de4cec.png' rel='icon' sizes='196x196' type='image/png'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/touch-icon-iphone-39bd7ff71b36a1437d9cdc23d45de04267ed070abc156637ed08c6afb707abb2.png' rel='apple-touch-icon'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/touch-icon-ipad-89e21b077e721efe918622cf72084b818542b98212077b8a665d9935dc03420c.png' rel='apple-touch-icon' sizes='76x76'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/touch-icon-iphone-retina-ead295fbd6456a78adad4424790c18f3780a9eaecbfa96f6326d1ae33a5075ff.png' rel='apple-touch-icon' sizes='120x120'>
<link href='//assets.moviepilot.com/cms_assets/moviepilot/touch-icon-ipad-retina-cc080fe1dcae84aee844f9f956d80492b4fa815e41e6b397d672996ebe21f536.png' rel='apple-touch-icon' sizes='152x152'>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'>
<meta content='width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no' name='viewport'>
<meta content='#50e3c2' name='theme-color'>
<meta content='unsafe-url' name='referrer'>
<title>Cheyenne Jackson Is Back In &#39;American Horror Story&#39; Season 7 | moviepilot.com</title>
<meta name="robots" content="index"/>
<meta name="keywords" content="americanhorrorstory, cheyennejackson, ryanmurphy, horror"/>
<meta name="description" content="&#39;American Horror Story&#39; alumni Cheyenne Jackson is back for the politically charged Season 7 of the horror anthology."/>
<meta name="fb:app_id" content="215662575119216"/>
<meta name="article:published_time" content="2017-05-29T05:25:17-04:00"/>
<meta name="article:modified_time" content="2017-05-29T05:53:13-04:00"/>
<meta name="article:author" content="Tom Chapman"/>
<meta name="article:tag" content="Horror"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://moviepilot.com/p/cheyenne-jackson-returns-american-horror-story-season-7/4281320"/>
<meta property="og:title" content="Cheyenne Jackson Is Back In &#39;American Horror Story&#39; Season 7"/>
<meta property="og:description" content="&#39;American Horror Story&#39; alumni Cheyenne Jackson is back for the politically charged Season 7 of the horror anthology."/>
<meta property="og:image" content="https://images.moviepilot.com/image/upload/c_fill,h_630,q_auto:best,w_1200/fcg43vvd8sqnquwigbic.jpg"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@creators"/>
<meta name="twitter:title" content="Cheyenne Jackson Is Back In &#39;American Horror Story&#39; Season 7"/>
<meta name="twitter:description" content="&#39;American Horror Story&#39; alumni Cheyenne Jackson is back for the politically charged Season 7 of the horror anthology."/>
<meta name="twitter:image" content="https://images.moviepilot.com/image/upload/c_fill,h_630,q_auto:best,w_1200/fcg43vvd8sqnquwigbic.jpg"/>
<link rel="canonical" href="https://moviepilot.com/p/cheyenne-jackson-returns-american-horror-story-season-7/4281320"/>
<link rel="amphtml" href="https://moviepilot.com/posts/4281320/amp"/>
<style>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</style>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="XdGmXe7Fkjf4IB3MfJnRpTFCd3dtXWXfvqMKyPZD+CrA4p4n5v7ssnRib5I8V4VvWfLy/2hZXnicqNP9gcoPlw==" />
<link href='https://assets.moviepilot.com' rel='preconnect'>
<link href='https://images.moviepilot.com' rel='preconnect'>
<link href='https://tower.moviepilot.com' rel='preconnect'>
<link href='https://js.creators.co' rel='preconnect'>
<link href='https://www.facebook.com' rel='preconnect'>
<link href='https://cdn.jsdelivr.net' rel='preconnect'>
<link href='/manifest' rel='manifest'>
<script>
  document.createElement("picture")
</script>
<script>
//<![CDATA[
window.gon={};gon.stage="production";gon.vertical={"name":"moviepilot","url":"https://moviepilot.com","hostName":"moviepilot.com","useAds":true};gon.verticals={"moviepilotUrl":"https://moviepilot.com","creatorsUrl":"https://creators.co","championsUrl":"https://champions.co","nowloadingUrl":"https://nowloading.co"};gon.page="story";gon.accounts={"facebookAppId":215662575119216,"GaAllVerticalsProperty":"UA-26688737-18","jwplayerId":"3fZat9SO"};gon.api={"creatorsApi":"https://login.creators.co","assetsUrl":"https://assets.moviepilot.com/js","canvasApi":"https://canvas-api.creators.co/post"};gon.content={"advertising":{"units":[{"dfpName":"desktopPanoramicFirst","className":".desktop-panoramic-1st"},{"dfpName":"desktopPanoramicSecond","className":".desktop-panoramic-2nd"},{"dfpName":"desktopLeaderboard","className":".desktop-leaderboard"},{"dfpName":"desktopSidebar","className":".desktop-sidebar"},{"dfpName":"mobileHeroFirst","className":".mobile-hero-1st"},{"dfpName":"mobileHeroSecond","className":".mobile-hero-2nd"},{"dfpName":"mobileRectangleFirst","className":".mobile-rectangle-1st"},{"dfpName":"mobileRectangleMid","className":".mobile-rectangle-mid"},{"dfpName":"mobileRectangleSecond","className":".mobile-rectangle-2nd"},{"dfpName":"mobileCustom","className":".mobile-custom"},{"dfpName":"desktopCustom","className":".desktop-custom"},{"dfpName":"desktopGumgum","className":".desktop-gumgum"},{"dfpName":"mobileGumgum","className":".mobile-gumgum"}],"adInjectionContainerClassName":"article-content","stickyAdsContainterClassName":"sticky-ads-containter"},"useAppboy":true,"useContactButton":false,"post":{"id":4281320,"title":"Chey My Name: Cheyenne Jackson Is Back In 'American Horror Story' Season 7","tags":["AmericanHorrorStory","CheyenneJackson","RyanMurphy","Horror"],"coverURL":"https://images.moviepilot.com/image/upload/c_fill,h_630,q_auto:best,w_1200/fcg43vvd8sqnquwigbic.jpg","hasPolls":true,"isHulunation":false,"isSonysundays":false,"commentsEnabled":true,"useAds":true,"hasJwplayerVideo":true,"isPublished":true,"author":{"id":3647101},"alwaysShowReadCounter":false},"comments":{"placeholder":"#comments"}};
//]]>
</script>
<script>
  var dataLayer = [];
  (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-K3PTLDL');
</script>

</head>
<body class=''>
<noscript>
<iframe height='0' src='https://www.googletagmanager.com/ns.html?id=GTM-K3PTLDL' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>

<svg version="1.1" xmlns="http://www.w3.org/2000/svg" style="display: none"><defs><symbol id="twitter" viewBox="0 0 800 800"><path d="M679 239s-21 34-55 57c7 156-107 329-314 329-103 0-169-50-169-50s81 17 163-45c-83-5-103-77-103-77s23 6 50-2c-93-23-89-110-89-110s23 14 50 14c-84-65-34-148-34-148s76 107 228 116c-22-121 117-177 188-101 37-6 71-27 71-27s-12 41-49 61c30-2 63-17 63-17z"></path></symbol>
<symbol id="facebook" viewBox="0 0 800 800"><path d="M445 643h-90V419h-75v-87h75v-64q0-55 32-86 30-29 80-29 28 0 67 3v78h-47q-42 0-42 38v60h86l-11 87h-75v224z"></path></symbol>
<symbol id="instagram" viewBox="0 0 800 800"><path d="M150 400c0-119 0-166 42-208s88-42 208-42 166 0 208 42 42 89 42 208 0 166-42 208-88 42-208 42-166 0-208-42-42-89-42-208zm455 0c0-114 0-148-29-176-29-29-62-29-176-29s-148 0-176 29c-29 29-29 62-29 176s0 148 29 176c29 29 62 29 176 29s148 0 176-29c29-29 29-62 29-176zM400 272a128 128 0 1 1 0 256 128 128 0 0 1 0-256zm0 211c46 0 83-37 83-83s-37-83-83-83-83 37-83 83 37 83 83 83zm163-216c0 16-13 30-30 30-16 0-30-14-30-30 0-17 14-30 30-30 17 0 30 13 30 30z"></path></symbol>
<symbol id="youtube" viewBox="0 0 800 800"><path d="M400 224c144 0 201 2 224 25 17 17 26 52.125 26 151s-9 134-26 151c-23 23-80 25-224 25s-201-2-224-25c-17-17-26-52.125-26-151s9-134 26-151c23-23 80-25 224-25zm-52 100v141l135-70z"></path></symbol>
<symbol id="pinterest" viewBox="0 0 800 800"><path d="M287 681c-9-3-15-77-6-115l38-163s-9-20-9-49c0-46 26-80 59-80 28 0 42 21 42 46 0 28-19 71-28 110-8 33 17 59 49 59 58 0 104-61 104-150 0-79-57-134-138-134-94 0-148 69-148 142 0 28 9.7 57.4 23 74 4 5 5 6 2 17l-8 31s-2 9.5-14 3c-41-22.3-63-78-63-126 0-104 75-199 217-199 114 0 203 81 203 190 0 113-72 205-171 205-55 0-75-38-75-38l-21 78c-11 41-47 102-56 99z"></path></symbol>
<symbol id="whatsapp" viewBox="0 0 800 800"><path d="M519 454c4 2 7 10-1 31-6 16-33 29-49 29-96 0-189-113-189-167 0-26 9-39 18-48 8-9 14-10 18-10h12c4 0 9 0 13 10l19 44c5 11-9 25-15 31-3 3-6 7-2 13 25 39 41 51 81 71 6 3 10 1 13-2l19-24c5-6 9-4 13-2zM401 200c-110 0-199 90-199 199 0 68 35 113 35 113l-20 74 76-20s42 32 108 32c110 0 199-89 199-199 0-111-89-199-199-199zm0-40c133 0 239 108 239 239 0 132-108 239-239 239-67 0-114-29-114-29l-127 33 34-124s-32-49-32-119c0-131 108-239 239-239z"></path></symbol>
<symbol id="loading" viewBox="0 0 70 20">
  <circle cx="10" cy="10" r="0">
    <animate attributeName="r" from="0" to="10" values="0;10;10;10;0" dur="1000ms" repeatCount="indefinite"></animate>
  </circle>
  <circle cx="35" cy="10" r="0">
    <animate attributeName="r" from="0" to="10" values="0;10;10;10;0" begin="200ms" dur="1000ms" repeatCount="indefinite"></animate>
  </circle>
  <circle cx="60" cy="10" r="0">
    <animate attributeName="r" from="0" to="10" values="0;10;10;10;0" begin="400ms" dur="1000ms" repeatCount="indefinite"></animate>
  </circle>
</symbol>
<symbol id="search" viewBox="-730.5 0.5 500 500" style="enable-background:new -730.5 0.5 500 500;">
  <g>
    <path d="M-343.9,357.3c30.9-37.7,49.5-85.8,49.5-138.4c0-120.5-97.7-218.2-218.2-218.2s-218.2,97.7-218.2,218.2       s97.7,218.2,218.2,218.2c52.2,0,100-18.3,137.6-48.8l114.8,111.3l29.4-32.7L-343.9,357.3z M-512.6,382.6       c-90.4,0-163.6-73.3-163.6-163.6S-603,55.3-512.6,55.3S-349,128.5-349,218.9S-422.3,382.6-512.6,382.6z"></path>
  </g>
</symbol>
<symbol id="mobile" viewBox="0 0 24.4 37.1"><style>.st0{enable-background:new}.st1{fill:#010101}.st2{fill:#fccc5b}.st3{fill:#020202}.st4,.st5,.st6{fill-rule:evenodd;clip-rule:evenodd;fill:#020202}.st5,.st6{fill:#010101}.st6{fill:#fccc5b}.st7{fill:#fccc5c}</style>
<path id="device" d="M0 4v29.1c0 2.2 1.8 4 4 4h16.4c2.2 0 4-1.8 4-4V4c0-2.2-1.8-4-4-4H4C1.8 0 0 1.8 0 4zm22.4 22.1H2V7.3h20.4v18.8zM2 28.1h20.4v5c0 1.1-.9 2-2 2H4c-1.1 0-2-.9-2-2v-5zM2 5.3V4c0-1.1.9-2 2-2h16.4c1.1 0 2 .9 2 2v1.3H2z"></path><path id="button" class="st2" d="M14.2 31.7c0 1.1-.9 2-2 2s-2-.9-2-2 .9-2 2-2 2 .9 2 2z"></path></symbol>
<symbol id="arrow-left" viewBox="0 0 30.1 48.9"><path d="M11.4 24.5L30.2 5.7 24.5 0 0 24.5 24.5 49l5.7-5.7-18.8-18.8z"></path></symbol>
<symbol id="arrow-right" viewBox="0 0 30.1 48.9"><path d="M18.8 24.5L0 43.3 5.7 49l24.5-24.5L5.7 0 0 5.7l18.8 18.8z"></path></symbol>
</defs></svg>

<div class='panoramic-ad-space-allocation panoramic_ad_placeholder'>
<div class='desktop-panoramic-1st-ad-container ad--centered'></div>
<div class='mobile-hero-1st-ad-container ad--centered'></div>
</div>
<nav class='header' id='header-normal' role='navigation'>
<form class='header__search-bar header__notification'>
<div class='content header__search-form'>
<input autofocus='true' class='header__search-input' placeholder='search'>
<button class='header__search-button'>
<span class='icon header__icon header__search-icon'>
<svg><use xlink:href="#search"></use></svg>
</span>
</button>
</div>
</form>
<div class='header__sections'>
<div class='header__section header__section--left'>
<a href='/'>
<svg class="header__logo" width="150px" height="150px" viewBox="0 0 150 150" version="1.1">
  <title>Movie Pilot</title>
  <desc>Logo of MoviePilot.com</desc>
  <defs>
    <rect id="path-1-normal" x="-2.55795385e-14" y="0" width="150.125436" height="150.3"></rect>
    <mask id="mask-2-normal" maskContentUnits="userSpaceOnUse" maskUnits="objectBoundingBox" x="0" y="0" width="150.125436" height="150.3" fill="white">
      <use xlink:href="#path-1-normal"></use>
    </mask>
    <rect id="path-1-hover" x="0" y="0" width="150.125436" height="150.3"></rect>
    <mask id="mask-2-hover" maskContentUnits="userSpaceOnUse" maskUnits="objectBoundingBox" x="0" y="0" width="150.125436" height="150.3" fill="white">
      <use xlink:href="#path-1-hover"></use>
    </mask>
    <filter x="-50%" y="-50%" width="200%" height="200%" filterUnits="objectBoundingBox" id="filter-3">
      <feOffset dx="0" dy="1" in="SourceAlpha" result="shadowOffsetOuter1"></feOffset>
      <feGaussianBlur stdDeviation="0.5" in="shadowOffsetOuter1" result="shadowBlurOuter1"></feGaussianBlur>
      <feColorMatrix values="0 0 0 0 0   0 0 0 0 0   0 0 0 0 0  0 0 0 0.5 0" type="matrix" in="shadowBlurOuter1" result="shadowMatrixOuter1"></feColorMatrix>
      <feMerge>
        <feMergeNode in="shadowMatrixOuter1"></feMergeNode>
        <feMergeNode in="SourceGraphic"></feMergeNode>
      </feMerge>
    </filter>
  </defs>
  <style>
    @media screen and (min-width: 459px) {
    #normal-icon * {
    transition: opacity 300ms ease-in-out;
    }
    #normal-icon:hover * {
    transition: opacity 300ms ease-in-out;
    opacity: 0;
    }
    }
  </style>
  <g id="hover-icon" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
    <g stroke="#50E3C2" stroke-width="21" fill="#2C0750">
      <use mask="url(#mask-2-hover)" xlink:href="#path-1-hover"></use>
    </g>
    <g filter="url(#filter-3)" transform="translate(23.700000, 29.100000)" fill="#50E3C2">
      <path d="M0.0420232001,9.9778624 L0.0335867995,9.9778624 L0.0335867995,92.0548734 L22.0238627,92.0548701 L22.0238627,92.0651064 L31.7430688,82.5912861 L31.7422418,67.0009 L31.7428816,34.2736107 L22.0222087,43.7335432 L24.6652595,50.0603537 L22.0206794,43.7308905 L22.0206794,82.5919103 L10.2672347,82.5919103 L10.2672347,9.98620865 L27.1189999,9.98620865 L47.0761375,55.2353299 L47.0749114,55.2383484 L47.0767007,55.2366069 L47.079839,55.2335524 L56.5319855,46.034 L56.5348386,46.0412515 L72.1415008,9.73566251 L93.3503211,9.73566215 L93.3503211,82.5938218 L93.3508985,82.5950311 L81.080172,82.5950311 L81.080172,33.7775435 L81.084666,33.7661336 L81.080172,33.7706217 L81.0786054,33.7721861 L71.6205182,43.2176384 L71.6205182,43.2152341 L58.8376428,74.6646342 L48.8830264,74.6646334 L31.7452691,34.2851507 L31.7452691,67.0023691 L37.8741648,82.5920273 L54.2359815,82.5920273 L54.2323138,82.5983392 L64.4582555,74.6679961 L64.4618216,74.6679961 L71.6194697,57.8006196 L71.6194697,92.066066 L93.351429,92.066066 L93.351429,92.0597177 L102.813542,82.5908804 L102.805909,82.5908804 L102.805908,0.0134019385 L76.7331199,0.0134019385 L66.5396522,9.72839941 L66.5155082,9.72839941 L53.7161444,38.8731329 L36.5944561,0.0134019385 L10.2633248,0.0134019385 L10.2633248,0.0185097667 L0.0420232001,9.9778624 Z"></path>
    </g>
  </g>
  <g id="normal-icon">
    <g transform="translate(0.101818, 0.000000)" stroke="#2C0750" stroke-width="21" fill="#50E3C2">
      <use mask="url(#mask-2-normal)" xlink:href="#path-1-normal"></use>
    </g>
    <g transform="translate(23.391638, 44.390930)" fill="#2C0750">
      <polygon points="30.2421147 29.7161924 30.2421147 2.06252485 22.6127646 2.06252485 15.1407206 18.5127094 7.66867668 2.06252485 0 2.06252485 0 29.7161924 6.25292099 29.7161924 6.25292099 11.7669503 12.8597809 26.9547706 17.4216604 26.9547706 24.0285203 11.7669503 24.0678468 29.7161924"></polygon>
      <path d="M0,37.1254474 L0,64.7396661 L7.00012538,64.7396661 L7.00012538,56.968236 L11.9945969,56.968236 C19.0340488,56.968236 23.0846831,53.220592 23.0846831,46.750975 C23.0846831,40.5969492 19.0340488,37.1254474 11.9945969,37.1254474 L0,37.1254474 Z M7.00012538,42.6482911 L11.6406579,42.6482911 C14.7081286,42.6482911 16.4778232,44.1078998 16.4778232,46.9876683 C16.4778232,49.9068858 14.7081286,51.4453922 11.6406579,51.4453922 L7.00012538,51.4453922 L7.00012538,42.6482911 Z"></path> <path d="M43.0271918,8.25009942 C36.066393,8.25009942 31.4258605,12.5500278 31.4258605,19.0985425 C31.4258605,25.6470572 36.066393,29.9864344 43.0271918,29.9864344 C49.9486641,29.9864344 54.5891967,25.6470572 54.5891967,19.0985425 C54.5891967,12.5500278 49.9486641,8.25009942 43.0271918,8.25009942 L43.0271918,8.25009942 Z M43.0271918,13.6545965 C45.8193767,13.6545965 47.7463775,15.9031829 47.7463775,19.1774402 C47.7463775,22.4911465 45.8193767,24.700284 43.0271918,24.700284 C40.1956805,24.700284 38.2686796,22.4911465 38.2686796,19.1774402 C38.2686796,15.9031829 40.1956805,13.6545965 43.0271918,13.6545965 L43.0271918,13.6545965 Z"></path>
      <polygon points="67.234659 29.7708634 75.217948 8.50791503 68.4537819 8.50791503 63.8525759 23.5379398 59.2906965 8.50791503 52.2905711 8.50791503 60.2738601 29.7708634"></polygon>
      <path d="M79.5674767,0 C77.4831697,0 75.9887609,1.49905759 75.9887609,3.58984843 C75.9887609,5.72008816 77.4831697,7.21914575 79.5674767,7.21914575 C81.6517837,7.21914575 83.1461925,5.72008816 83.1461925,3.58984843 C83.1461925,1.49905759 81.6517837,0 79.5674767,0 L79.5674767,0 Z M82.9102332,29.5952387 L82.9102332,8.33229034 L76.1460671,8.33229034 L76.1460671,29.5952387 L82.9102332,29.5952387 Z"></path>
      <path d="M94.7671913,8.25009942 C88.1996579,8.25009942 83.7164315,12.5894766 83.7164315,19.1774402 C83.7164315,25.6470572 88.0423517,29.9864344 94.963824,29.9864344 C98.8571522,29.9864344 102.042602,28.6057235 104.205563,26.2387905 L100.626847,22.7278398 C99.2110911,24.1479996 97.4020699,24.8975284 95.5537222,24.8975284 C93.0368232,24.8975284 91.227802,23.4773686 90.5592507,20.95264 L105.464012,20.95264 C105.935931,13.1812099 102.239235,8.25009942 94.7671913,8.25009942 L94.7671913,8.25009942 Z M90.4412711,17.2838938 C90.8738631,14.7197164 92.4862515,12.9839655 94.8458444,12.9839655 C97.2840903,12.9839655 98.9358053,14.6802675 98.9358053,17.2838938 L90.4412711,17.2838938 Z"></path>
      <polygon points="39.2597092 64.5378793 39.2597092 36.8676318 32.4562165 36.8676318 32.4562165 64.5378793"></polygon>
      <path d="M51.7852185,43.0552063 C44.8244197,43.0552063 40.1838871,47.3551347 40.1838871,53.9036494 C40.1838871,60.4521641 44.8244197,64.7915413 51.7852185,64.7915413 C58.7066908,64.7915413 63.3472234,60.4521641 63.3472234,53.9036494 C63.3472234,47.3551347 58.7066908,43.0552063 51.7852185,43.0552063 L51.7852185,43.0552063 Z M51.7852185,48.4597034 C54.5774034,48.4597034 56.5044042,50.7082898 56.5044042,53.9825472 C56.5044042,57.2962534 54.5774034,59.5053909 51.7852185,59.5053909 C48.9537071,59.5053909 47.0267063,57.2962534 47.0267063,53.9825472 C47.0267063,50.7082898 48.9537071,48.4597034 51.7852185,48.4597034 L51.7852185,48.4597034 Z"></path>
      <path d="M76.651406,58.8137577 C75.6289158,59.2476954 74.7244052,59.5238376 74.0165274,59.5238376 C72.7580778,59.5632865 72.0502,58.8532065 72.0502,57.1963534 L72.0502,47.5005038 L77.5952431,47.5005038 L77.5952431,43.0033311 L72.0502,43.0033311 L72.0502,37.1254474 L65.2860339,37.1254474 L65.2860339,43.04278 L62.3365429,43.04278 L62.3365429,47.5005038 L65.2860339,47.5005038 L65.2860339,58.2614733 C65.2860339,62.6797483 68.2355249,65.0072324 72.3254858,65.0072324 C74.3704663,65.0072324 76.4547733,64.4549481 77.9885086,63.5476237 L76.651406,58.8137577 Z"></path>
      <path d="M27.7920837,35.0629225 C25.7077767,35.0629225 24.2133679,36.5619801 24.2133679,38.652771 C24.2133679,40.7830107 25.7077767,42.2820683 27.7920837,42.2820683 C29.8763907,42.2820683 31.3707995,40.7830107 31.3707995,38.652771 C31.3707995,36.5619801 29.8763907,35.0629225 27.7920837,35.0629225 L27.7920837,35.0629225 Z M31.1348402,64.6581613 L31.1348402,43.3952129 L24.3706741,43.3952129 L24.3706741,64.6581613 L31.1348402,64.6581613 Z"></path>
    </g>
  </g>
</svg>

</a>

</div>
<div class='header__section_wrapper header__section--center'>
<div class='header__section header__section--contextual'>
<div class='header__subsection header__subsection--default'>
<span class='header__subsection-flexed'>
<a class='link header__title header__link text--no-break' data-track='engagement header|main cta|_location_' href='https://moviepilot.com/join'>
Start Writing
</a>
</span>
<div class='header__subsection-flexed'>
<ul class='header__categories--list hidden@small hidden@smaller-than-content inline list-inline' role='menu'>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to superheroes|_location_' href='/hashtags/superheroes'>
SUPERHEROES
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to horror|_location_' href='/hashtags/horror'>
HORROR
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to young adult|_location_' href='/hashtags/Youngadult'>
YOUNG ADULT
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to television|_location_' href='/hashtags/tv'>
TELEVISION
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to video|_location_' href='/video'>
VIDEO
</a>
</li>

</ul>
<span class='icon header__icon header__search-icon' id='header__search-trigger'>
<svg><use xlink:href="#search"></use></svg>
</span>
<span class='header__sharing hidden@small'>
<a class='facebook header__sharing-item' data-action='share/facebook/share' href='https://www.facebook.com/moviepilotdotcom'>
<span class='icon header__icon'>
<svg><use xlink:href="#facebook"></use></svg>
</span>
</a>
<a class='header__sharing-item twitter' data-action='share/twitter/share' href='https://twitter.com/moviepilotnews'>
<span class='icon header__icon'>
<svg><use xlink:href="#twitter"></use></svg>
</span>
</a>
<a class='header__sharing-item pinterest' data-action='share/pinterest/share' href='https://www.pinterest.com/moviepilot'>
<span class='icon header__icon'>
<svg><use xlink:href="#pinterest"></use></svg>
</span>
</a>
<a class='header__sharing-item instagram' data-action='share/instagram/share' href='https://www.instagram.com/supernewslive'>
<span class='icon header__icon'>
<svg><use xlink:href="#instagram"></use></svg>
</span>
</a>

</span>
</div>
</div>
<div class='header__subsection header__subsection--contextual'>
<span class='header__title truncate'>
Chey My Name: Cheyenne Jackson Is Back In 'American Horror Story' Season 7
</span>
<a class='header__title header__subtitle link' href='https://creators.co/@tchapman'>
Tom Chapman
</a>
<span class='header__sharing header__sharing--inverted hidden@small'>
<a class='header__sharing-item facebook colored' data-action='share/facebook/share' data-network='facebook'>
<span class='icon header__icon'>
<svg><use xlink:href="#facebook"></use></svg>
</span>
</a>
<a class='header__sharing-item twitter colored' data-action='share/twitter/share' data-network='twitter'>
<span class='icon header__icon'>
<svg><use xlink:href="#twitter"></use></svg>
</span>
</a>
<a class='header__sharing-item pinterest colored' data-action='share/pinterest/share' data-network='pinterest'>
<span class='icon header__icon'>
<svg><use xlink:href="#pinterest"></use></svg>
</span>
</a>
</span>
</div>

</div>
</div>
<div class='header__menu-wrapper'>
<input class='header__menu-toggler' id='toggler' type='checkbox'>
<div class='header__menu'>
<label class='hamburger__icon absolute-center' data-track='engagement header|open or close dropdown|_location_' for='toggler'>
<span></span>
</label>
<ul class='header__menu-menu menu' role='menu'>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|write_for_us|_location_' href='https://moviepilot.com/join'>
Write For Us
</a>
</li>

<li class='menu__item' role='menuitem'>
<a class='header__title link header__link' data-action='login' href='https://creators.co/sign_in?ref='>Log In</a>
</li>
<li class='menu__item menu__break' role='menuitem'>
<a class='header__title link header__link' data-track='engagement header|open chat|_location_' href='https://creators.co/creators-chat' target='_blank'>Chat</a>
</li>
<li class='hidden@larger-than-content menu__item' role='menuitem'>
<ul class='header__categories--list menu__break' role='menu'>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to superheroes|_location_' href='/hashtags/superheroes'>
SUPERHEROES
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to horror|_location_' href='/hashtags/horror'>
HORROR
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to young adult|_location_' href='/hashtags/Youngadult'>
YOUNG ADULT
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to television|_location_' href='/hashtags/tv'>
TELEVISION
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|link to video|_location_' href='/video'>
VIDEO
</a>
</li>

</ul>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|jobs|_location_' href='https://creatorsmedia.workable.com'>
Jobs
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|about_us|_location_' href='https://moviepilot.com/about'>
About Us
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|contact_us|_location_' href='https://moviepilot.com/posts/2479546'>
Contact Us
</a>
</li>
<li role='menuitem'>
<a class='link header__title header__link' data-track='engagement header|tos|_location_' href='https://moviepilot.com/terms'>
Terms Of Service
</a>
</li>

<li class='menu__item'>
<span class='header__sharing hidden@large'>
<a class='facebook header__sharing-item' data-action='share/facebook/share' href='https://www.facebook.com/moviepilotdotcom'>
<span class='icon header__icon'>
<svg><use xlink:href="#facebook"></use></svg>
</span>
</a>
<a class='header__sharing-item twitter' data-action='share/twitter/share' href='https://twitter.com/moviepilotnews'>
<span class='icon header__icon'>
<svg><use xlink:href="#twitter"></use></svg>
</span>
</a>
<a class='header__sharing-item pinterest' data-action='share/pinterest/share' href='https://www.pinterest.com/moviepilot'>
<span class='icon header__icon'>
<svg><use xlink:href="#pinterest"></use></svg>
</span>
</a>
<a class='header__sharing-item instagram' data-action='share/instagram/share' href='https://www.instagram.com/supernewslive'>
<span class='icon header__icon'>
<svg><use xlink:href="#instagram"></use></svg>
</span>
</a>

</span>
</li>
</ul>
</div>
</div>
</div>

</nav>
<nav class='header header--fixed header--social header--hidden' id='header-social' role='navigation'>
<span class='header__sharing header__sharing--inverted'>
<a class='header__sharing-item whatsapp' data-action='share/whatsapp/share' data-network='whatsapp'>
<span class='icon header__icon'>
<svg><use xlink:href="#whatsapp"></use></svg>
</span>
</a>
<a class='header__sharing-item twitter' data-action='share/twitter/share' data-network='twitter'>
<span class='icon header__icon'>
<svg><use xlink:href="#twitter"></use></svg>
</span>
</a>
<a class='header__sharing-item facebook' data-action='share/facebook/share' data-network='facebook'>
<span class='icon header__icon'>
<svg><use xlink:href="#facebook"></use></svg>
</span>
</a>
<a class='header__sharing-item header__next-article-link' data-track='navigate|next article|_location_' href='https://moviepilot.com/p/alien-xenomorph-kills-symbolism-gay-penis-rape/4272704'>
Next article
<svg viewBox="0 0 53.2 49"><path d="M41.8 24.5L23 43.3l5.7 5.7 24.5-24.5L28.7 0 23 5.7z"></path><path d="M18.8 24.5L0 43.3 5.7 49l24.5-24.5L5.7 0 0 5.7z"></path></svg>

</a>
</span>
</nav>

<article class='article-page'>
<header class='article-header'>
<div class='content'>
<div class='article-header__card'>
<a class='article-header__hashtag' href='/hashtags/Horror'>#Horror</a>
<h1 class='article-header__title'>Chey My Name: Cheyenne Jackson Is Back In 'American Horror Story' Season 7</h1>
<time class='article-header__date' datetime='2017-05-29T05:53:13-04:00' sdk-convert-date='local'>May 29, 2017 at 05:53AM</time>
<p class='article-header__author'>
By
<a href='https://creators.co/@tchapman' rel='author'>Tom Chapman</a>,
writer at
<a class='author-card__site-link' data-track='navigate|article author section|from vertical to creators.co' href='https://creators.co/'>
creators.co
</a>
</p>
</div>
<div class='user-dependent' data-user-id='3647101'>
<div class='current-user'>
<div class='article-header__stats' id='stats'>
<div class='layout layout--inline'>
<svg class="icon icon--centered"><use xlink:href="#loading"></use></svg>
</div>

</div>
</div>
</div>
<figure class='article-header__image-wrap'>
<img alt="&#39;American Horror Story&#39; [Credit: FX]" class="article-header__image" width="620" height="470" src="https://images.moviepilot.com/image/upload/c_fill,h_470,q_auto:good,w_620/fcg43vvd8sqnquwigbic.jpg" />
<figcaption class='article-header__image-caption'>
'American Horror Story' [Credit: FX]
</figcaption>
</figure>
</div>
</header>
<div class='article-body content layout--ad'>
<div class='article-main'>
<dl class='author-card'>
<dt class='author-card__title'>
By<a class='author-card__name' href='https://creators.co/@tchapman'>Tom Chapman</a>, writer at
<a class='author-card__site-link' data-track='navigate|article author section|from vertical to creators.co' href='https://creators.co/'>
Creators.co
</a>
</dt>
<dd class='author-card__description'>tweet: tomtomchap  Warden of the North - bearded, tattooed and square eyed 'til the end</dd>
<dd class='author-card__avatar-wrap'>
<a class='author-card__avatar-link' href='https://creators.co/@tchapman'>
<img class="author-card__avatar" width="72" height="72" alt="Tom Chapman" src="https://images.moviepilot.com/image/upload/c_fill,h_72,q_auto:good,w_72/dfis1izzlip9bnhjnr8k.jpg" />
</a>
</dd>
</dl>

<div class='article-content'>
<div class='for-small-devices hidden supplication'>
<a href='https://creators.co/@bk-one/3859150' rel='nofollow' target='_blank'>
<figure>
<img class='supplication-image' data-src='https://images.moviepilot.com/image/upload/c_scale,q_80,w_300/v1481038784/supplication/mp_s.jpg'>
</figure>
</a>
</div>

<p>With the urge to purge and another murderously OTT season of <a class="article-content__hashtag" rel="tag" title="American horror story" href="/hashtags/AmericanHorrorStory">#AmericanHorrorStory</a> on the way, fans are baying for information (and blood) on the show's return. We may have seen some <a href="https://moviepilot.com/p/ahs-season-7-monster-instagram/4263169"><i>Dumbo</i>-nightmare concept art </a>of the season's presumed Big Bad and had some promises of political strife in Washington, but apart from a few casting tidbits, we've been kept in the dark.</p><p>There may be no Trump and no Clinton — I'm still holding out for Kathy Bates as POTUS — however, we now know that another <i>AHS</i> alumni will be saluting the Star Spangled Banner in September. Alongside the likes of Evan Peters, Sarah Paulson, and of course Ms. Bates, resident <i>Horror Story</i> hunk <a class="article-content__hashtag" rel="tag" title="Cheyenne jackson" href="/hashtags/CheyenneJackson">#CheyenneJackson</a> will be back in an unspecified role for Season 7 of FX's horror anthology.</p><h2>Back For 'Gore'</h2><p>The square-jawed lothario will once again be opening himself up to the masterful mind of <a class="article-content__hashtag" rel="tag" title="Ryan murphy" href="/hashtags/RyanMurphy">#RyanMurphy</a> and hand himself over to this year's circus of political debauchery. Let's just hope that we get to see a little more of him than we did in Season 6 before he takes ANOTHER puncture wound to the throat.</p><p>Just Jared’s paparazzi snapped Jackson on set the set of<i> American Horror Story</i> in Los Angeles, and previously reported that Evan Peters had been spotted too. Jackson was noticeably seen alongside Sarah Paulson, so does this mean that the two will be sharing some sordid screen time, or could Jackson have something to do with <a href="https://moviepilot.com/p/american-horror-story-season-7-teaser-evan-peters-blue-hair/4275394">Evan Peter and his rumored new hairdo</a>? </p><p>It is only a first glimpse, but showing a knack for a villain role in Season 6's <i>Roanoke</i>, you can easily imagine Jackson as some weasely White House spin doctor who gets his comeuppance. Jackson joined the fray in Season 5's <i>Hotel</i>, where he played the hapless homosexual Will Drake. It didn't take long for the corridors of the Hotel Cortex to lure Drake in, and he met a similarly gruesome fate in Season 6. Appearing last year as the slimy director Sidney James, the 41-year-old felt sadly underused in the show's most divisive season yet. </p><p>While Jackson's return is sure to be a coup for fans of <i>AHS</i>'s anthology premise, new talent like <a href="https://moviepilot.com/p/bllie-lourd-american-horror-story-first-look/4278040">Billie Lourd</a>, Billy Eichner, and Leslie Grossman promise to spray some fresh blood over the proceedings. There is still no news on if fan-favorites like Angela Bassett and Lily Rabe are sharpening their butcher knives, but expect Murphy to capitalize on whichever A-list stars he can snare. </p><p>With previous stars including Leslie Jordan, Jessica Lange, and Lady Gaga, at least <i>American Horror Story </i>can't be accused of skimping on the talent or the corn syrup. Either way, we are sure that "Yucky No. 7" will weave an intricate web of political murder and deceit that even Frank Underwood would be proud of. </p><p><b>Check out Jackson as Sidney James in <i>American Horror Story</i> and don't forget our poll below!</b></p><p><div class="embedded embedded--full-width" data-jwvideo="GnKKhUjl" itemscope itemtype="http://schema.org/VideoObject">
<meta content="American Horror Story 6x07 Promo" itemprop="name">
<meta content="American Horror Story 6x07 [[embed:309179]]quot;Chapter 7[[embed:309179]]quot; - What did you think of the game-changing twist? Check out the promo for Chapter 7 of American Horror Story Season 6: Roanoke airing Wednesday October 26th on FX." itemprop="description">
<meta content="2016-10-22T14:51:48Z" itemprop="uploadDate">
<meta content="https://content.jwplatform.com/videos/GnKKhUjl-1280.mp4" itemprop="contentURL">
<meta content="https://content.jwplatform.com/thumbs/GnKKhUjl-1280.jpg" itemprop="thumbnailURL">
<meta content="PT30S" itemprop="duration">
<div id="jwplayer-GnKKhUjl">
<div class="layout layout--inline">
<svg class="icon icon--centered"><use xlink:href="#loading"></use></svg>
</div>

</div>
</div>

</p><p><div class="poll poll--not-voted">
<span class="poll__header">
Poll
</span>
<h3 class="poll__question">
Are you glad that Cheyenne Jackson is returning to 'American Horror Story'?
</h3>
<form class="poll__form" data-poll-uuid="347338fa-32dd-4920-a5bb-5bae0e2780d2">
<ul class="poll__answers">
<li class="poll__answer">
<input type="radio" name="poll-71143" id="answer-236013" value="c014cc49-2b7b-4832-855a-c1c3ac8e64c7" disabled>
<label class="poll-answer__content" for="answer-236013">
Yes - I think he is great
<span class="poll-result-bar"></span>
<span class="poll-radio"></span>
</label>
</li>
<li class="poll__answer">
<input type="radio" name="poll-71143" id="answer-236014" value="df833f39-ba04-49a5-b88c-cc8c237a2f7e" disabled>
<label class="poll-answer__content" for="answer-236014">
No - he is an awful actor
<span class="poll-result-bar"></span>
<span class="poll-radio"></span>
</label>
</li>
<li class="poll__answer">
<input type="radio" name="poll-71143" id="answer-236015" value="ef590d20-169e-4a32-8f8f-4d0255b3893e" disabled>
<label class="poll-answer__content" for="answer-236015">
He is good, but he isn't my fave!
<span class="poll-result-bar"></span>
<span class="poll-radio"></span>
</label>
</li>

</ul>
</form>
</div>

</p><p>(Source: <a href="http://www.justjared.com/2017/05/27/cheyenne-jackson-confirmed-for-ahs-season-7-spotted-filming-on-set-photos/">Just Jared)</a></p><p></p>
</div>
<div class='comments-content'>
<div class='section-header section-header--comments'>
<span class='section-header__title'>
Comments
</span>
<a class='comments-creators-link' data-track='engagement comments|link to creators|_location_' href='https://creators.co'>
<img class="comments-creators-link__logo" src="//assets.moviepilot.com/cms_assets/creators-logo-31e92731792c29b3359cc0c9adfabc6b4c746bfd0bbdec039628588dd74705ae.svg" alt="Creators logo" />
Powered by Creators
</a>
</div>
<div id='comments'></div>
</div>
<div class='promoted-content'>
<div class='OUTBRAIN centred-ad fullwidth-ad' data-ob-template='MoviePilot' data-src='DROP_PERMALINK_HERE' data-widget-id='AR_2'></div>
<div class='revcontent'>
<div class='centred-ad fullwidth-ad' id='rcjsload_8b16f1'></div>
<div class='centred-ad fullwidth-ad' id='rcjsload_3e3230'></div>
<div class='centred-ad fullwidth-ad' id='rcjsload_190ffa'></div>
</div>
</div>
<br>
<div class='nativo-article-0'></div>
<div class='nativo-article-1'></div>
<div class='mobile-hero-2nd-ad-container'></div>
<section class='latest-content'>
<div class='section-header'>
<h2 class='section-header__title'>
Latest
<span class='desktop-only'>
from our
<a class='section-header__link' href='#'>
Creators
</a>
</span>
</h2>
</div>
<ul class='layout layout--inline'>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/zac-efron-the-rock-baywatch-kiss-scene-taste/4281326'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/eeisdcdjrrqezadqxivf.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/eeisdcdjrrqezadqxivf.jpg'>
<img alt="Zac Efron Describes What The Rock Tasted Like During Their 'Baywatch' Kiss Scene" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/eeisdcdjrrqezadqxivf.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/Baywatch'>
#Baywatch
</a>
<h3 class='card__title'>
<a href='/p/zac-efron-the-rock-baywatch-kiss-scene-taste/4281326'>Zac Efron Describes What The Rock Tasted Like During Their &#39;Baywatch&#39; Kiss Scene</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@TheComicProf'>
The Comic Professor
</a>
on
<time datetime="2017-05-29">May 29, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/legends-of-tomorrow-seaosn-3-vixed-return-confirmed/4281324'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/it02pyfkfi7pjsgvhfw2.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/it02pyfkfi7pjsgvhfw2.jpg'>
<img alt="'DC's Legends of Tomorrow': Maisie Richardson-Sellers Confirms Vixen Will Return In Season 3, But How?" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/it02pyfkfi7pjsgvhfw2.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/HVFF'>
#HVFF
</a>
<h3 class='card__title'>
<a href='/p/legends-of-tomorrow-seaosn-3-vixed-return-confirmed/4281324'>&#39;DC&#39;s Legends of Tomorrow&#39;: Maisie Richardson-Sellers Confirms Vixen Will Return In Season 3, But How?</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@DavidOpie'>
David Opie
</a>
on
<time datetime="2017-05-29">May 29, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/arrowverse-stars-mehcad-brooks-stephen-amell-john-barrowman-manchester-attacks/4281329'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/vcdjnn4jaqazlkvtdg4x.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/vcdjnn4jaqazlkvtdg4x.jpg'>
<img alt="The Arrowverse's Mehcad Brooks, Stephen Amell &amp; John Barrowman Offer Words Of Comfort In Wake Of Manchester Attacks" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/vcdjnn4jaqazlkvtdg4x.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/HVFF'>
#HVFF
</a>
<h3 class='card__title'>
<a href='/p/arrowverse-stars-mehcad-brooks-stephen-amell-john-barrowman-manchester-attacks/4281329'>The Arrowverse&#39;s Mehcad Brooks, Stephen Amell &amp; John Barrowman Offer Words Of Comfort In Wake Of Manchester Attacks</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@TomBacon'>
Tom Bacon
</a>
on
<time datetime="2017-05-29">May 29, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/hayley-atwell-cancelled-agent-carter-season-3-plot-cliffhanger/4281342'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/zz9nv4j0qltetgk70fub.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/zz9nv4j0qltetgk70fub.jpg'>
<img alt="Hayley Atwell Reveals What We Could Have Seen In 'Agent Carter' Season 3: Could It Ever Happen?" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/zz9nv4j0qltetgk70fub.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/AgentCarter'>
#AgentCarter
</a>
<h3 class='card__title'>
<a href='/p/hayley-atwell-cancelled-agent-carter-season-3-plot-cliffhanger/4281342'>Hayley Atwell Reveals What We Could Have Seen In &#39;Agent Carter&#39; Season 3: Could It Ever Happen?</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@TomBacon'>
Tom Bacon
</a>
on
<time datetime="2017-05-29">May 29, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/cheyenne-jackson-returns-american-horror-story-season-7/4281320'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/fcg43vvd8sqnquwigbic.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/fcg43vvd8sqnquwigbic.jpg'>
<img alt="Chey My Name: Cheyenne Jackson Is Back In 'American Horror Story' Season 7" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/fcg43vvd8sqnquwigbic.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/Horror'>
#Horror
</a>
<h3 class='card__title'>
<a href='/p/cheyenne-jackson-returns-american-horror-story-season-7/4281320'>Chey My Name: Cheyenne Jackson Is Back In &#39;American Horror Story&#39; Season 7</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@tchapman'>
Tom Chapman
</a>
on
<time datetime="2017-05-29">May 29, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/stephen-amell-season-6-theme-death-william-samantha/4280784'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/adfxncf466f74fz4jfuu.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/adfxncf466f74fz4jfuu.jpg'>
<img alt="'Arrow': Stephen Amell Reveals Theme Of Season 6, Perhaps Confirming Who Died In The Season 5 Finale" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/adfxncf466f74fz4jfuu.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/Arrow'>
#Arrow
</a>
<h3 class='card__title'>
<a href='/p/stephen-amell-season-6-theme-death-william-samantha/4280784'>&#39;Arrow&#39;: Stephen Amell Reveals Theme Of Season 6, Perhaps Confirming Who Died In The Season 5 Finale</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@DavidOpie'>
David Opie
</a>
on
<time datetime="2017-05-29">May 29, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/katie-cassidy-black-siren-meet-white-canary-arrow-season-6-laurel-lance/4280792'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/imbkh38sivelmmtnqeiy.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/imbkh38sivelmmtnqeiy.jpg'>
<img alt="'Arrow': Katie Cassidy Hints That Black Siren Will Finally Meet White Canary In Season 6, But Will They Be Enemies?" class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/imbkh38sivelmmtnqeiy.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/Arrow'>
#Arrow
</a>
<h3 class='card__title'>
<a href='/p/katie-cassidy-black-siren-meet-white-canary-arrow-season-6-laurel-lance/4280792'>&#39;Arrow&#39;: Katie Cassidy Hints That Black Siren Will Finally Meet White Canary In Season 6, But Will They Be Enemies?</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@DavidOpie'>
David Opie
</a>
on
<time datetime="2017-05-28">May 28, 2017</time>
</span>
</div>
</article>

</li>
<li class='layout__item layout__item--half'>
<article class='card'>
<a class='card__img' href='/p/is-katy-perry-taylor-swift-feud-over/4280066'>
<picture>
<source media='(min-width: 539px)' srcset='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/mqbe6i64egj4dleuwm5g.jpg'>
<source srcset='https://images.moviepilot.com/image/upload/c_fill,h_225,q_auto:good,w_300/mqbe6i64egj4dleuwm5g.jpg'>
<img alt='No More Bad Blood: Does Katy Perry Want To Make Up With Taylor Swift?' class='card__background-img' src='https://images.moviepilot.com/image/upload/c_fill,h_340,q_auto:good,w_460/mqbe6i64egj4dleuwm5g.jpg'>
</picture>
</a>
<div class='card__body'>
<a class='card__category' href='https://moviepilot.com/hashtags/Celebrity'>
#Celebrity
</a>
<h3 class='card__title'>
<a href='/p/is-katy-perry-taylor-swift-feud-over/4280066'>No More Bad Blood: Does Katy Perry Want To Make Up With Taylor Swift?</a>
</h3>
<span class='card__author'>
by
<a class='card__author-link' href='https://creators.co/@dimarisleigh'>
Dimaris 
</a>
on
<time datetime="2017-05-28">May 28, 2017</time>
</span>
</div>
</article>

</li>

</ul>

</section>

</div>
<aside class='article-sidebar layout--ad__sidebar'>
<div class='desktop-sidebar-ad-container'>
<div class='for-big-devices hidden supplication'>
<a href='https://creators.co/@bk-one/3859150' rel='nofollow' target='_blank'>
<figure>
<img class='supplication-image' data-src='https://images.moviepilot.com/image/upload/c_scale,q_80,w_300/v1481038787/supplication/mp_l.jpg'>
</figure>
</a>
</div>

</div>
<section class='read-next layout-wrap'>
<div class='section-header'>
<h3 class='section-header__title'>
What to read next
</h3>
</div>
<ul class='layout layout--stacked read-next__list'>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/posts/3820089'>
<img class="card__background-img" width="64" height="64" alt="Voldemort - Origins of The Heir: A New Fan-film Project" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/hu33nmmkj9cdtwntphwy.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/posts/3820089'>
Voldemort - Origins of The Heir: A New Fan-film Project
</a>
<span class='card__author'>
<a href='https://creators.co/users/3819825'>
by

</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/p/ellen-degeneres-forgot-katy-perry-was-married-to-russell-brand/4271240'>
<img class="card__background-img" width="64" height="64" alt="Ellen Forgot All About Katy Perry&#39;s Marriage To Russell Brand And It Was AWKS AF" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/jykxxckt4dm0rnvozegu.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/p/ellen-degeneres-forgot-katy-perry-was-married-to-russell-brand/4271240'>
Ellen Forgot All About Katy Perry's Marriage To Russell Brand And It Was AWKS AF
</a>
<span class='card__author'>
<a href='https://creators.co/@heathers'>
by
Heather Snowden
</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/p/all-netflix-secret-codes-unlock-full-movie-tv-library/4271777'>
<img class="card__background-img" width="64" height="64" alt="All Of Netflix&#39;s Secret Codes To Unlock Its Full Library of Movies And TV Shows, All In One Place" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/sximhmqldopy35hlkxcr.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/p/all-netflix-secret-codes-unlock-full-movie-tv-library/4271777'>
All Of Netflix's Secret Codes To Unlock Its Full Library of Movies And TV Shows, All In One Place
</a>
<span class='card__author'>
<a href='https://creators.co/@ellemcf'>
by
Elle McFarlane
</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/p/alien-xenomorph-kills-symbolism-gay-penis-rape/4272704'>
<img class="card__background-img" width="64" height="64" alt="&#39;Alien&#39;: Once You Know What The Xenomorphs Were Originally Planned For, You’ll Never Look At Them In The Same Way Again" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/hbsmh01dw3rwykuakbri.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/p/alien-xenomorph-kills-symbolism-gay-penis-rape/4272704'>
'Alien': Once You Know What The Xenomorphs Were Originally Planned For, You’ll Never Look At Them In The Same Way Again
</a>
<span class='card__author'>
<a href='https://creators.co/@DavidOpie'>
by
David Opie
</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/p/netflix-the-keepers-tells-victims-stories/4275209'>
<img class="card__background-img" width="64" height="64" alt="Netflix Series &#39;The Keepers&#39; Will Absolutely Enrage You And That&#39;s A Good Thing" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/csmofprre821hxpanrvv.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/p/netflix-the-keepers-tells-victims-stories/4275209'>
Netflix Series 'The Keepers' Will Absolutely Enrage You And That's A Good Thing
</a>
<span class='card__author'>
<a href='https://creators.co/@allanah'>
by
Allanah Faherty
</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/p/amc-s-ballistic-city-to-get-kosinski-d/926867'>
<img class="card__background-img" width="64" height="64" alt="AMC&#39;s &#39;Ballistic City&#39; to get Kosinski&#39;d" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/-e837b84b-712a-4c9a-8663-3117601c7856.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/p/amc-s-ballistic-city-to-get-kosinski-d/926867'>
AMC's 'Ballistic City' to get Kosinski'd
</a>
<span class='card__author'>
<a href='https://creators.co/@Alisha'>
by
Alisha Grauso
</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/posts/1157726'>
<img class="card__background-img" width="64" height="64" alt="Sienna Miller joins Vince Vaughn on Business Trip" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/uploads_029d372f-8549-41da-be11-365dac9fde13-sienna_milelr-jpg-7526.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/posts/1157726'>
Sienna Miller joins Vince Vaughn on Business Trip
</a>
<span class='card__author'>
<a href='https://creators.co/@Tino'>
by
Tino Jochimsen
</a>
</span>
</div>
</article>
</li>
<li class='layout__item--stacked'>
<article class='card card--inline'>
<a class='card__img card__img--squared' href='https://moviepilot.com/posts/2443362'>
<img class="card__background-img" width="64" height="64" alt="These Fan-Made Frozen and Captain America 2 VHS Trailers Will Cause NOSTALGIC OVERLOAD!" src="https://images.moviepilot.com/image/upload/c_fill,h_64,q_auto,w_64/these-fan-made-frozen-and-captain-america-2-vhs-trailers-will-cause-nostalgic-overload-jpeg-176473.jpg" />
</a>
<div class='card__body card__body--inline'>
<a class='card__title' href='https://moviepilot.com/posts/2443362'>
These Fan-Made Frozen and Captain America 2 VHS Trailers Will Cause NOSTALGIC OVERLOAD!
</a>
<span class='card__author'>
<a href='https://creators.co/@PeterD'>
by
Peter DiDonato
</a>
</span>
</div>
</article>
</li>

</ul>
</section>

<div class='sticky-ads-containter'></div>
</aside>
</div>
<div class='desktop-panoramic-2nd-ad-container'></div>
<div class='mobile-custom-ad-container'></div>
<div class='desktop-custom-ad-container'></div>
<div class='desktop-gumgum-ad-container'></div>
<div class='mobile-gumgum-ad-container'></div>

<img width="0" height="0" src="https://tower.moviepilot.com/tower.gif?event=read&amp;path%5B%5D=external&amp;target=posts%3A4281320&amp;url=https%3A%2F%2Fmoviepilot.com%2Fp%2Fcheyenne-jackson-returns-american-horror-story-season-7%2F4281320" alt="Tower.gif?event=read&amp;path%5b%5d=external&amp;target=posts%3a4281320&amp;url=https%3a%2f%2fmoviepilot" />
</article>

<script>
  (function(e,t){typeof module!="undefined"&&module.exports?module.exports=t():typeof define=="function"&&define.amd?define(t):this[e]=t()})("$script",function(){function p(e,t){for(var n=0,i=e.length;n<i;++n)if(!t(e[n]))return r;return 1}function d(e,t){p(e,function(e){return t(e),1})}function v(e,t,n){function g(e){return e.call?e():u[e]}function y(){if(!--h){u[o]=1,s&&s();for(var e in f)p(e.split("|"),g)&&!d(f[e],g)&&(f[e]=[])}}e=e[i]?e:[e];var r=t&&t.call,s=r?t:n,o=r?e.join(""):t,h=e.length;return setTimeout(function(){d(e,function t(e,n){if(e===null)return y();!n&&!/^https?:\/\//.test(e)&&c&&(e=e.indexOf(".js")===-1?c+e+".js":c+e);if(l[e])return o&&(a[o]=1),l[e]==2?y():setTimeout(function(){t(e,!0)},0);l[e]=1,o&&(a[o]=1),m(e,y)})},0),v}function m(n,r){var i=e.createElement("script"),u;i.onload=i.onerror=i[o]=function(){if(i[s]&&!/^c|loade/.test(i[s])||u)return;i.onload=i[o]=null,u=1,l[n]=2,r()},i.async=1,i.src=h?n+(n.indexOf("?")===-1?"?":"&")+h:n,t.insertBefore(i,t.lastChild)}var e=document,t=e.getElementsByTagName("head")[0],n="string",r=!1,i="push",s="readyState",o="onreadystatechange",u={},a={},f={},l={},c,h;return v.get=m,v.order=function(e,t,n){(function r(i){i=e.shift(),e.length?v(i,r):v(i,t,n)})()},v.path=function(e){c=e},v.urlArgs=function(e){h=e},v.ready=function(e,t,n){e=e[i]?e:[e];var r=[];return!d(e,function(e){u[e]||r[i](e)})&&p(e,function(e){return u[e]})?t():!function(e){f[e]=f[e]||[],f[e][i](t),n&&n(r)}(e.join("|")),v},v.done=function(e){v([null],e)},v})
</script>

<script>
  window.creators = {
    subscribers: [],
    config: gon,
    onReady: function (callback) {
      this.subscribers.push(callback)
    }
  }
  
  window.creators.has = function(blankSeparatedPath) {
    var args = blankSeparatedPath.split(' ')
  
    var obj = this.config
    for (var i = 0; i < args.length; i++) {
      if (!obj || !obj.hasOwnProperty(args[i])) {
        return false;
      }
      obj = obj[args[i]];
    }
    return !(typeof(obj) === "undefined");
  }
  
  window.creators.get = function (blankSeparatedPath) {
    if (!this.has(blankSeparatedPath)){
      console.warn("Attribute doesn't exist", blankSeparatedPath)
      return null
    }
  
    var args = blankSeparatedPath.split(' ')
    var obj = this.config
    for (var i = 0; i < args.length; i++) {
      obj = obj[args[i]];
    }
    return obj;
  }
  
  function getAssetsUrl (path) {
    return creators.get('api assetsUrl') + '/' + path
  }
</script>

<script>
  $script(getAssetsUrl('vendor/core.2.4.1.min.js'), 'polyfills')
  
  $script.ready(['zepto', 'polyfills'], function () {
    $script(getAssetsUrl('sdk/11.0.0/' + creators.get('vertical name') +'/bundle.js'), 'sdk')
  })
</script>
<script>
  $script.ready(['zepto', 'polyfills'], function () {
    $script(getAssetsUrl('srtraficante/4.6.3.js'), 'traficante')
  })
</script>
<script>
  $script(getAssetsUrl('vendor/advertising.js'), 'trafica')
</script>
<script>
  $script.ready('trafica', function(){
    $script(getAssetsUrl('vendor/image-load.js'), 'il')
  })
</script>
<script>
  $script.ready(['il', 'trafica', 'zepto'], function () {
    if (!window.hasP){
      document.querySelectorAll('.supplication').forEach($element => {
        $element.classList.remove('hidden')
        const  $img = $element.querySelector('img')
        $img.setAttribute('src', $img.dataset.src)
      })
    }
  })
</script>

<script>
  $script(getAssetsUrl('vendor/zepto.1.1.6.min.js'), 'zepto')
</script>
<script>
  setTimeout(function () {
    var reportMissingDeps = function(depsNotFound) {
      dataLayer.push({
        event: 'trackEvent',
        eventCategory: 'Dependency missing',
        eventAction: 'JS-Error',
        eventLabel: depsNotFound.toString()
      })
    }
    var reportBrokenSdk = function() {
      dataLayer.push({
        event: 'trackEvent',
        eventCategory: 'Dependency missing',
        eventAction: 'JS-Error',
        eventLabel: 'creators-sdk'
      })
    }
    var brokenSdkReport = setTimeout(reportBrokenSdk, 5000)
    var dependencies = ['sdk', 'polyfills', 'zepto']
  
    $script.ready(dependencies, function () {
      // cancel timeout if sdk is available and responding
      window.creators.onReady(function () {
        clearTimeout(brokenSdkReport)
      })
    }, reportMissingDeps)
  }, 8000)
</script>




<script src="//assets.moviepilot.com/cms_assets/post-65cf60f466ea8f487a7446f97464caf4a7c1549d9f416a9d6060900a944a8ef0.js"></script>

<script type="application/ld+json">
//<![CDATA[
{"@context":"http://schema.org","@type":"Article","mainEntityOfPage":"https://moviepilot.com/p/cheyenne-jackson-returns-american-horror-story-season-7/4281320","headline":"Chey My Name: Cheyenne Jackson Is Back In 'American Horror Story' Season 7","alternativeHeadline":"Cheyenne Jackson Is Back In 'American Horror Story' Season 7","position":4281320,"image":{"@type":"ImageObject","url":"https://images.moviepilot.com/image/upload/c_fill,h_630,q_auto:best,w_1200/fcg43vvd8sqnquwigbic.jpg","width":"1200","height":"630"},"publisher":{"@type":"Organization","name":"Movie Pilot","logo":{"@type":"ImageObject","url":"https://moviepilot.com/moviepilot/favicon_w600.png","height":"60","width":"600"},"URL":"https://moviepilot.com"},"datePublished":"2017-05-29T05:25:17-04:00","dateModified":"2017-05-29T05:53:13-04:00","author":{"@type":"Person","name":"Tom Chapman","URL":"https://creators.co/@tchapman","alternateName":"tchapman"},"description":"'American Horror Story' alumni Cheyenne Jackson is back for the politically charged Season 7 of the horror anthology.","keywords":["americanhorrorstory","cheyennejackson","ryanmurphy","horror"]}
//]]>
</script>
</body>
</html>
